The 4th Unit Project

*Required* if you are taking class for 4 credits

*Offered for extra credit* (5%) if you are taking class for 3 credits and *cannot* take it for 4 credits
Project Idea:
Reliable Real-time Information Distillation from the Physical World

Physical World
- Civil Unrest
- Hurricanes
- Man-made disasters

People → Information

Sensors
There exists a unique “ground truth” state (vector) is being estimated. As opposed to: opinion mining, sentiment analysis, statistical correlation mining, ...
Reconstructing Event Timelines
The Apollo Fact-finder

- Credibility of sources
- Correctness of claims
- Confidence intervals

Events
- Civil Unrest
- Hurricanes
- Man-made disasters

Sources

Claims

Attribute: Credibility

Attribute: True/False

Maximum Likelihood Estimation

- Formulate the fact-finding problem as one of maximum likelihood estimation
- Solve it using the Expectation Maximization (EM) algorithm
- Compute a bound on estimation accuracy (using the Cramer Rao Bound)

Clean Event Summary
Social Channel “Decoding”
A Maximum Likelihood Estimation Problem

- Joint estimation of
  - Source reliability
  - True/false value of each observation

- Given
  - Who said what

\[
P(SC|\theta) = \sum_z P(SC, z|\theta)
\]
Apollo: A Social Sensing System with a Twitter Front-end
Humans as (Noisy) Sensors

- Example of tweets collected in the aftermath of the Syrian chemical weapons attack in August 2013.
- Tweets were crawled for ten days after the event using the keywords “Syria”, “attack”, “dead”.
- Table shows results of maximum likelihood estimation, automatically separating tweets into “socially corroborated” and “not corroborated”.

<table>
<thead>
<tr>
<th>Triage Result: Recommended for Viewing</th>
<th>Triage Result: Dismissed/Unimportant</th>
</tr>
</thead>
<tbody>
<tr>
<td>Medecins Sans Frontieres says it treated about 3,600 patients with 'neurotoxic symptoms' in Syria, of whom 355 died</td>
<td>So sad. All but one of the activists who filmed the chemical attack in Syria died of toxins: <a href="http://t.co/7Xc9u8achL">http://t.co/7Xc9u8achL</a></td>
</tr>
<tr>
<td>Weapons expert says #Syria footage of alleged chemical attack “difficult to fake” <a href="http://t.co/zJDMujACTV">http://t.co/zJDMujACTV</a></td>
<td>Saudis offer Russia secret oil deal if it drops Syria via @Telegraph <a href="http://t.co/OUtxsiaRs">http://t.co/OUtxsiaRs</a></td>
</tr>
<tr>
<td>U.N. experts in Syria to visit site of poison gas attack <a href="http://t.co/086Ofxnf">http://t.co/086Ofxnf</a> via @reuters #PINET</td>
<td>Putin Orders Massive Strike Against Saudi Arabia If West Attacks Syria <a href="http://t.co/SFLJ9gbwht">http://t.co/SFLJ9gbwht</a></td>
</tr>
<tr>
<td>Syria Gas Attack: 'My Eyes Were On Fire' <a href="http://t.co/s6MiHJ0Em">http://t.co/s6MiHJ0Em</a></td>
<td>Syria Chemical Weapons Attack Carried Out by Rebels, Says UN (UPDATE) <a href="http://t.co/in4ckUePuJ">http://t.co/in4ckUePuJ</a> #Syria <a href="http://t.co/TorVFUZF">http://t.co/TorVFUZF</a></td>
</tr>
<tr>
<td>Long-term nerve damage feared after Syria chemical attack <a href="http://t.co/08w7BiOxQR">http://t.co/08w7BiOxQR</a></td>
<td>For those in the US, please text SYRIA to 864233 to donate $10 via @unicefusa <a href="http://t.co/YMXnrk1jcb">http://t.co/YMXnrk1jcb</a> #childrenofsyria</td>
</tr>
<tr>
<td>Syrian official blames rebels for deadly attack <a href="http://t.co/76mcy4qb">http://t.co/76mcy4qb</a></td>
<td>We may be going to war in Syria, and somehow Miley Cyrus Is trending on twitter</td>
</tr>
<tr>
<td>Assad regime responsible for Syrian chemical attack, says UK government <a href="http://t.co/pM257CsNZ">http://t.co/pM257CsNZ</a></td>
<td>Syrian Chemical Weapons Attack Carried Out by Rebels, Says UN (UPDATE) <a href="http://t.co/in4ckUePuJ">http://t.co/in4ckUePuJ</a> #Syria <a href="http://t.co/TorVFUZF">http://t.co/TorVFUZF</a></td>
</tr>
<tr>
<td>US forces move closer to Syria as options weighed: WASHINGTON (AP) — U.S. naval forces are moving closer to Syria... <a href="http://t.co/F6UAAXL52M">http://t.co/F6UAAXL52M</a></td>
<td>Syria Gas Attack: 'My Eyes Were On Fire' <a href="http://t.co/s6MiHJ0Em">http://t.co/s6MiHJ0Em</a></td>
</tr>
<tr>
<td>400 tonnes of arms sent into Syria through Turkey to boost Syria rebels after CW attack in Damascus --&gt; <a href="http://t.co/KLwESYCHC">http://t.co/KLwESYCHC</a></td>
<td>Attack! <a href="http://t.co/05KKn7R3s">http://t.co/05KKn7R3s</a></td>
</tr>
<tr>
<td>UN Syria team departs hotel as Assad denies attack <a href="http://t.co/O3sQoPoi0x">http://t.co/O3sQoPoi0x</a></td>
<td>Attack! <a href="http://t.co/05KKn7R3s">http://t.co/05KKn7R3s</a></td>
</tr>
<tr>
<td>Vehicle of @UN #Syria #ChemicalWeapons team hit by sniper fire. Team replacing vehicle &amp; then returning to area.</td>
<td>A fathers last words to his dead daughters killed by Bashar al-Assad &amp; his supporter army with chemical weapon attack <a href="http://t.co/DN25pJcQ8">http://t.co/DN25pJcQ8</a></td>
</tr>
<tr>
<td>International weapons experts leave Syria. U.S. prepares attack. More @ <a href="http://t.co/4zw2R9QKOE">http://t.co/4zw2R9QKOE</a></td>
<td>What the media isn’t telling you about the Syrian chemical attack <a href="http://t.co/LQ7993Itv">http://t.co/LQ7993Itv</a></td>
</tr>
<tr>
<td>Military strike on Syria would cause retaliatory attack on Israel, Iran declares <a href="http://t.co/M9s0x5VcW">http://t.co/M9s0x5VcW</a></td>
<td>France on the phone. Apparently they surrendered to #Syria weeks ago.</td>
</tr>
<tr>
<td>Asia markets fall on Syria concerns: Asian stocks fall, extending a global market sell-off sparked by growing ... <a href="http://t.co/06a9h2xCnJ">http://t.co/06a9h2xCnJ</a></td>
<td>Poll: Do you think the chemical attack in #Syria could have been a false flag attack to push for war? RT for yes. Favourite for no</td>
</tr>
<tr>
<td>UK Prime Minister Cameron loses Syria war vote (from @AP) <a href="http://t.co/ULFF1wY9gX">http://t.co/ULFF1wY9gX</a></td>
<td>Lebanon was once part of Syria and will forever be with Syria. #PrayForSyria #PrayForLebanon</td>
</tr>
</tbody>
</table>
Extensions:

- The current estimation framework makes simplifying assumptions on sources and observations (e.g., independence)
  - How to detect copying/influence?
  - How to account for source non-independence due to information dissemination?
  - How to account for physical relations between observations?
  - How to include inference and other logical relations when some observations imply others?
  - How to separate “opinions” from ground-truthable facts?
  - How to de-bias observations?
  - How to detect degree of “polarization” among sources?
  - How to compute fundamental error bounds?
  - How to influence sources such as error bound is reduced?
The Social Signal: An Analogy

Physical target

Response of physical propagation medium (e.g., acoustic, vibration, optical, ...)

Received signature (energy in multiple signal frequency bands)
An Analogy

- **Physical target**
  - Response of physical propagation medium (e.g., acoustic, vibration, optical, ...)
  - Received signature (energy in multiple signal frequency bands)

- **Physical event**
  - Response of social propagation medium (e.g., tweets)
  - Received signature (energy in multiple keyword frequency bands)
Demultiplexing

- A world of “protest” – this morning:
  - Angry French farmers and 1,000 tractors head for Paris protest. Photo @MartinBureau1 #AFP http://t.co/j5DdveSHZh
  - VIDEO: Tractor protest descends on Paris: French farmers protesting about high taxes have taken a convoy of tr... http://t.co/hKievMFpq3
  - WATCH LIVE: Farmers on tractors gather in Paris streets https://t.co/peTOvKrIAF http://t.co/3vDK6qc060
  - MORE: Police detained refugees who lay on train tracks in protest at being taken to a camp, This is 2015 not 1940's http://t.co/TbQrwWBWrH
  - RIGHT NOW: Activists & giant polar bear protest Arctic oil outside Shell London HQ http://t.co/1Ae9mgc1ZF #ArcticRoar http://t.co/5tJaKv0mHZ
  - Underwater sculptures emerge from Thames in climate change protest http://t.co/mg6RiURn6t
Events and Signal Processing: The Lexical Frequency Domain

**Observation:** Targets can be recognized using frequency domain signatures

**Question:** Can we detect and track events using “frequency domain” signatures only?

- At first glance: text has complex semantics, so the ordering of keywords has great impact on meaning
  - “John killed Mary” versus “Mary killed John”

- Do we need natural language processing to identify and track distinct events?
Events and Signals: A Data Association Problem

- Easy to associate data with events (Sparsely populated feature space)
- Hard to associate data with events (Densely populated feature space)
A Signal Sparsity Observation

- Most languages have about 10,000 frequent words.
- Consider a 2-word event signature
  - There are at least 100,000,000 possible signatures
- Number of “events” in a Twitter data trace may be in the 100s or 1000s
- The space of keyword signatures is vastly sparse:
  - Different events $\rightarrow$ Different signatures (assuming independent keywords)
Event Detection, Consolidation, and Tracking: Signal Processing Questions

- How to detect new event signatures?
  - Find high-information-gain signatures (new spikes in the frequency spectrum)
  - Bin tweets that contain a new signature into a cluster
  - Determine if this cluster is of a new event or not using frequency domain distance (note: some events will have more than one signature)
Event Detection, Consolidation and Tracking

Three key ideas:
1. Use information gain to detect new keyword pairs (event signatures)
2. Each pair gives rise to a cluster of tweets (that contain the pair)
3. Merge clusters with similar keyword distributions

Automatically detected high-information-gain keyword pairs
Clusters of tweets containing keyword pairs
Event track
Time
Distance Metrics
(For Merging Event Data Clusters)

- Cosine similarity
- Term frequency difference
- Jaccard distance
- KL divergence

Clusters of tweets containing keyword pairs
Event Tracks
Recognizing Distinct Event Tracks

- Project contribution: Efficient algorithms that “demultiplex” Twitter feed into sub-streams associated with different events in a class (e.g., different concurrent flashmobs or different concurrent protests)

<table>
<thead>
<tr>
<th>Protest Name</th>
<th>Tweets</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bangladesh protests</td>
<td>Religion Bangladesh braces for Protests After Islamist’s Execution: senior official of the largest Islamis... <a href="http://t.co/NTBmlWSW">http://t.co/NTBmlWSW</a> &lt;br&gt;World News: Bangladesh braced for protests after Islamists leader’s execution: Bangladeshi security personnel s... <a href="http://t.co/UPKiaFFWy">http://t.co/UPKiaFFWy</a> &lt;br&gt;Bangladesh braces for protests after Jamaat leaders execution: Bangladesh braced for protests and fresh violen... <a href="http://t.co/3dcPfQKAME">http://t.co/3dcPfQKAME</a></td>
</tr>
<tr>
<td>Brazil protests</td>
<td>Protests across Brazil seek ouster of president <a href="http://t.co/YmXZnsxbAQ">http://t.co/YmXZnsxbAQ</a> &lt;br&gt;FollowMePlease Brazil braces for nationwide protests, as groups seeking impeachment of presiden... <a href="http://t.co/5T150D0z1L">http://t.co/5T150D0z1L</a> BrinaldyHere &lt;br&gt;Fresh anti-government protests in Brazil: Brazil on Sunday braced for more huge demonstrations against governm... <a href="http://t.co/8nJmX56MUm">http://t.co/8nJmX56MUm</a></td>
</tr>
<tr>
<td>Turkey protests</td>
<td>DTN Turkey: Turkey protests to Pope Francis after he brands Armenian killings 'genocide': Pontiff’s run-in wit... <a href="http://t.co/dKx5iCwP9w">http://t.co/dKx5iCwP9w</a> &lt;br&gt;Pope refers to Armenian genocide; Turkey protests. 24 April is 100th anniversary of start of the Armenian genocide <a href="http://t.co/ZFOCZnC411">http://t.co/ZFOCZnC411</a> &lt;br&gt;Telegraph: Turkey protests to Pope Francis after he brands Armenian killings 'genocide’ <a href="http://t.co/YnJew4fnN1">http://t.co/YnJew4fnN1</a> <a href="http://t.co/O6d5oYwG2p">http://t.co/O6d5oYwG2p</a></td>
</tr>
</tbody>
</table>
The Social Signal Layer

Social Sensing Signal, $Signal (k)$

Event Detection and Tracking

Event Data (Tweets Associated with the Event)

Social Medium
Observers of Physical Events

Event Map
Events and Trajectories

Event
Marathon
Protest
Flash mob

Keywords
Frequency counts

Keywords
Event Localization with Instagram

- Taking a picture requires being on location
- There is a substantial overlap between Twitter users and Instagram users
  - Implication: Many shared hashtags/labels
- “Demultiplex” events on Twitter, identify relevant keywords/hashtags, search Instagram, find location!
Instagram Localization

- Tracking “LA Marathon”
Instagram

- Tracking “LA Marathon”
Instagram Tracking

- Tracking “LA Marathon”: Early Stage
Instagram Tracking

- Tracking “LA Marathon”: Middle
Instagram Tracking

- Tracking “LA Marathon”: Late Stage
Challenge: Extractive Summarization

Build a data service that allows applications to retrieve (extractive) data summaries at arbitrary levels of granularity in accordance with an application-specific redundancy metric.
Customizability: The Distance Metric

Data Object → Application Callback → Feature Vector → Difference Function → Distance Metric

(Difference Function (Must obey triangle inequality))
Customizability: The Distance Metric

Opaque type (not interpreted by service)

Application specific functions (customization API)

Distance Metric
(Must obey triangle inequality)
Customizability: The Distance Metric

Examples: Scalars, vectors, pictures, text, etc.

Data Object

Application Callback

Feature Vector

Difference Function

Distance Metric

(Must obey triangle inequality)

Data Object

Application Callback

Feature Vector
Customizability: The Distance Metric

Data Object → Application Callback → Feature Vector → Difference Function → Distance Metric (Must obey triangle inequality)

Data Object → Application Callback → Feature Vector
Customizability: The Distance Metric

Data Object → Application Callback → Feature Vector → Difference Function → Distance Metric (Must obey triangle inequality) → Hierarchical Clustering

Customizability: The Distance Metric

Data Object

Application Callback

Feature Vector

Difference Function

Distance Metric

Hierarchical Clustering
Summarization

Data Object

Application Callback

Feature Vector

Difference Function

Distance Metric
(Must obey triangle inequality)

Hierarchical Clustering
Summarization

Data Object

Application Callback

Feature Vector

Difference Function

Distance Metric
(Must obeys triangle inequality)

Hierarchical Clustering
Hierarchical Clustering

Data Object

Application Callback

Feature Vector

Difference Function

Distance Metric

(Must obey triangle inequality)

Data Object

Application Callback

Feature Vector

Hierarchical Clustering

Summarization
Summarization

Representative sampling versus noise reduction?
A Network Paradigm Shift

Communication → Information Distillation

**The data fire-hose effect**

- **Present Networks**
  - **Goal:** Communication
    - Maximizes bit throughput between end-points
    - Most data is “logical”
    - Protocols geared primarily for point-to-point communication
    - Data loss may be a problem

- **Future Distillation Networks**
  - **Goal:** Information Distillation
    - Maximizes *information flow*
    - Much data is “physical”
    - Protocols geared for data filtering, and aggregation
    - Data loss may be a feature intended to reduce less informative bits
A Primary Network Design Challenge

- How to build networks that maximize useful information flow from the physical world?
Information-maximizing Prioritization

- Determine transmission order?
Information-maximizing Prioritization

- Determine transmission order?
Information-maximizing Prioritization

- Determine transmission order?
Information-maximizing Prioritization

- Determine transmission order?
Information-maximizing Prioritization

- Determine transmission order?
Information-maximizing Prioritization

- Determine transmission order?
Information-maximizing Prioritization

- Determine transmission order?

Coverage-monotonic scheduling
Information-maximizing Prioritization

Note: Coverage can be defined in an abstract feature space

Coverage-monotonic scheduling
Example: Data Forwarding in Disruption-tolerant Networks

A big disaster strikes a city...

- Volunteers are recruited
- They scout the area, capture pictures and send them to a rescue center
- Network constraints prevent sending all pictures

Images are collected from the Internet

- Hurricane Katrina 2005
- Nepal earthquake 2015
- Thailand flood 2011
Challenge: Data Selection to Maximize Coverage

- Fire on 6th and Main.
- Collapse on Park Ave.
- Flooding on State St.
- Structural damage on Pier Square
Example of Bad Coverage

Fire on 6th and Main.

Collapse on Park Ave.

An Example of Poor Data Selection (Low Coverage)
Example of Good Coverage

Fire on 6th and Main.

Collapse on Park Ave.

An Example of Good Data Selection (High Coverage)

Flooding on State St.

Structural damage on Pier Square
A Scheduling Approach: Coverage-maximizing Priorities

- Implement coverage-maximizing in-network prioritization for forwarding and storage
  - Objects are forwarded/dropped in a priority order aimed to maximize coverage of delivered content
    - Objects similar to previously forwarded ones get lower priority
  - Challenge: Forwarding and dropping must be made aware of the degree of semantic redundancy (i.e., similarity) between objects